Skip to content

L’IPv6 sous Windows XP c’est toute une histoire


Voilà quelques temps que je tente de faire fonctionner l’IPv6 sous Windows XP. Ce n’est pas une mince affaire!!!

J’ai actuellement un réseau comme suivant :

Mon réseau IPv6

Alors les tests qui fonctionnent correctement :

  • Ping :
C:\\>ping6 www.free.fr
Envoi d'une requête 'Ping' www.free.fr 2a01:e0c:1:1599::1 à partir de 2001:470:c897::10 avec 32 octets de données :
Réponse de 2a01:e0c:1:1599::1 : octets = 32 temps=86 ms Réponse de 2a01:e0c:1:1599::1 : octets = 32 temps=88 ms Réponse de 2a01:e0c:1:1599::1 : octets = 32 temps=87 ms Réponse de 2a01:e0c:1:1599::1 : octets = 32 temps=86 ms
Statistiques de Ping pour 2a01:e0c:1:1599::1 : Paquets : envoyés = 4, reçus = 4, perdus = 0 (0% de perte), Durée approximative des boucles en millisecondes : Minimum = 86ms, maximum = 88ms, moyenne = 86ms
  • Traceroute :
C:\\>tracert6 www.free.fr
Détermination de l'itinéraire vers www.free.fr 2a01:e0c:1:1599::1 de 2001:470:c897::10 avec un maximum de 30 sauts :
1 1 ms 1 ms 1 ms 2001:470:c897::1 2 65 ms 64 ms 63 ms jdenoy-1.tunnel.tserv10.par1.ipv6.he.net 2001:470:1f12:238::1 3 63 ms 63 ms 64 ms gige-g2-3.core1.par1.he.net 2001:470:0:7b::1 4 70 ms 70 ms 70 ms 10gigabitethernet1-3.core1.lon1.he.net 2001:470:0:42::1 5 78 ms 79 ms 79 ms 2001:7f8:4::3022:1 6 86 ms 88 ms 87 ms bzn-crs16-1-be1102.intf.routers.proxad.net 2a01:e00:1:a::1 7 87 ms 87 ms 87 ms bzn-6k-sys-po20.intf.routers.proxad.net 2a01:e00:1:3::2 8 88 ms 88 ms 87 ms 2a01:e0c:1:1599::1
Itinéraire déterminé.
  • C:\\>telnet 2a01:e0c:1:1599::1 80
GET http://www.free.fr/adsl/index.html <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"> <html xmlns="http://www.w3.org/1999/xhtml"> <head> <!Metas> <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" /> <meta http-equiv="Content-Language" content="fr" /> <meta name="Revisit-after" content="15" /> <meta name="robots" content="index,follow" />     <link rel="shortcut icon" href="http://www.free.fr/favicon.ico" type="image/x-icon">     <link rel="icon" href="http://www.free.fr/favicon.ico" type="image/x-icon"> <meta name="keywords" content="Free, adsl, offres adsl, internet, t.l.phone, t.l.phonie, mobiles, forfaits mobiles, tv, t.l.vision, VOD, vid.o . la demande, multiposte, radio, wifi, routeur, freeplayer, freebox, multiplay, d.groupage, total, partiel, e-mail, mail, m.l, fournisseur d'acc.s, I.S.P., isp, internaute, internautes, France, fran.ais" /> <meta name="description" content="Jusqu.. 28 M.ga, 10Go d.espace disque, WiFi-MiMo, Ligne t.l.phonique, Appels illimit.s vers 70 destinations, 250 cha.nes de t.l.vision, Vid.o . la Demande" /> <title>Freebox, la meilleure offre ADSL: Internet, T.l.phone, T.l.vision</title>
.. ..
</script> </body> </html>

Jusque la tout va bien, le sniffer me confirme bien que je cause IPv6 avec le monde entier.

Maintenant l’horreur :

Firefox sous Windows XP vers le sites www.free.fr (seul site d’un gros FAI Francais en IPv6), et bien le CPU du PC passe à 100% : Windows - Firefox - IPv6

Maintenant le truc sympa, c’est que le site répond bien.. L’échange des packets ce fait comme suivant : Free.fr Analyse de la comm IPv6

Vous voyez bien le fameux “3-way handshake”, mais après mon PC veut plus rien savoir, le CPU passe à 100%, et le site envois toutes les 6 à 10 secondes (pour les trois premières fois) à nouveau le SYN/ACK, puis je renvois le ACK, mais après plus rien!!!! (Bon j’ai quand même coupé au bout de 10 minutes. (Fichier pcap disponible ici)

Alors cela a été testé pour les navigateurs suivants :

  1. IE 6
  2. IE 7
  3. Firefox 2.0-3.0.1

Par contre pour le navigateur Opéra 9.52 (testé avec la 8 aussi), aucun soucis pour joindre les sites.

Je suis un peux dans le flou. Surtout que ca fonctionne sous Firefox sous Linux! Dans pas un problème de navigateur (sauf si c’est codé complètement différement) Je pense que ca doit être une fonction dans une DLL qui est utilisée sous Windows par les deux et pas Opéra.

Pour ceux qui aurait une idée, voici la conf de mon PC :

#======================== # Configuration de l'interface #======================== pushd interface ipv6 install reset
set state 6over4=disabled set privacy state=disabled add route prefix=::/0 interface="Wifi" metric=0 nexthop=2001:470:c897::1 add address interface="Wifi" address=2001:470:c897::10 set teredo type=disabled popd # Fin de la configuration de l'interface
# -- # Configuration ISATAP # -- pushd interface ipv6 isatap set state disabled popd # Fin de la configuration ISATAP
# -- # Configuration de 6to4 # -- pushd interface ipv6 6to4 reset set state state=disabled

Alors si un expert IPv6, ou juste quelqu’un qui saurait faire fonctionner l’IPv6 entièrement en natif (hors 6to4, Teredo, etc..) sous Windows XP, je serais preneur de toutes informations 🙂

Pour info, cette configuration fonctionne correctement sous Windows Vista en configurant le stack IPv6 de la carte réseau.

Published inIPv6

7 Comments

  1. zahraoui zahraoui

    j’ai le meme probleme moi aussi pas de solution, ca serais bien que quelqu’un nous aides

  2. zahraoui zahraoui

    je suis habitué a utiliser firefox, alors ce que j’ai fait c’est ke j’ai tapé about:config dans la barre d’adresse et j’ai changé le parametre network.dns.disableIPv6 en true. ca desactive l’ipv6 dans le navigateur mais ca permet de surfer sans blocage jusqu’a ce qu’on trouve une solution meilleure.

  3. @zahraoui : certes c’est ce que j’ai fait aussi, mais pour aller sur des sites uniquement en IPv6, tu peut utiliser Opéra 🙂 Ou alors passer sous Linux…

  4. mrk mrk

    salut
    je me retrouve confronté au même problème, j’utilise la manip décrite ci dessus mais comme j’aime résoudre les problèmes que je rencontre je me demandais si une solution avait été trouvé depuis?

    cordialement
    mrk

  5. zahraoui zahraoui

    toujours rien pour moi….

  6. @mrk / @zahraoui : malheureusement après multiple relances chez Microsoft, ils ne ce décident pas à ce bouger… En même temps, la seule solution qui n’est pas réellement envisageable consiste à passer sous Windows Vista :(. Cependant en voyant l’usine à gaz que cet OS est, je ne suis pas trop décidé à basculer du coté obscure de la force.

    Moi je veux un PC pour travailler, mais sans toutes les guirlandes de noël, widgets, barre et tout le tralala…

    Johan

Laisser un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.